Platform login issues
Incident Report for HG Insights
Resolved
This incident has been resolved.
Posted Apr 06, 2024 - 19:32 PDT
Investigating
Platform logins, Discovery, and Focus are inaccessible. We are currently investigating this issue.
Posted Apr 06, 2024 - 18:30 PDT
This incident affected: HG Insights Platform.