HG Insights Platform Login Unavailable
Incident Report for HG Insights
Resolved
This incident has been resolved.
Posted Jul 15, 2021 - 21:41 PDT
Investigating
Scheduled maintenance is taking longer than expected, and login to the platform is not currently available.
Posted Jul 15, 2021 - 20:55 PDT
This incident affected: HG Insights Platform.