Platform Partial Outage - Market Intelligence
Incident Report for HG Insights
Resolved
This incident has been resolved.
Posted Nov 02, 2023 - 15:00 PDT
Identified
We are currently experiencing an issue with Market Intelligence - the issue is being investigated
Posted Nov 02, 2023 - 14:39 PDT
This incident affected: HG Insights Platform.